Asteroids@home New CUDA application for Windows x64 Release

BOINC News

Well-Known Member
We are proud to present you the new CUDA application that was released by our team yesterday.

What's improved?
- We've Added support for latest Compute Capabilities (CC). Application was built with latest CUDA SDK v10.2 adding support for latest NVIDIA devices with Compute Capabilities (CC). This build supports CC 3.0, 3.5, 3.7, 5.0, 5.2, 6.0, 6.1, 7.0, & 7.5 from Kepler, Maxwell, Pascal, Volta & Turing architectures and their GeForce, Quadro, NVS and Tesla series, but does NOT supports Tegra and Jetson SoC Series devices (CC 3.2, 5.3, 6.2 & 7.2) which are not subject of interest for this project.
- Fixed issue with special Light curves which has more than 1000 points.

There is no x86 (32bit) version. CUDA 10.2 supports x64 (64bits) operating systems only.

Side effects that could be observed because of the update.
If your client shows unusual "Remaining time" for the tasks you can follow these steps:
1) Set "No new tasks" from "Project" tab for "Asteroids@Home" project.
2) Then you need to finish your recently downloaded tasks.
3) When all are done and reported to the server please reset the project with 'Reset project' button at Project tab.

We also suggest to use the latest stable version 7.14.0 of BOINC client.

And last but not least we strongly suggest users, who has CUDA enabled devices to upgrade their drivers to the latest one. For today it is 442.74 - WHQL. You will find it here: https://www.nvidia.com/Download/driverResults.aspx/158759/en-us
For legacy drivers you will find drivers here: https://www.geforce.com/drivers/beta-legacy

Despite new CUDA application is release we will continue to support older devices with older drivers by the previous CUDA55 application.

I would also like to thank Georgi Vidinski who made this release possible.


Radim Vančo (FoxKyong)

Continue reading...
 

Nick Name

Administrator
USA team member
I'll run some test WU's, I hope it's better than the previous GPU app because that one was terribly inefficient.
 

Nick Name

Administrator
USA team member
This application explicitly requires the latest driver: "Asteroids@home 3/23/2020 10:09:20 PM NVIDIA GPU: Upgrade to the latest driver to use all of this project's GPU applications"

I hate upgrading drivers on machines that are working well.(n) If I do this it will be at a later time.
 
Top